INC173849 - Degradation to the Form3 - UK Instant service
Incident Report for Form3
Postmortem

On Friday 27th October 2023, Form3 observed a degradation to the Form3 UK Instant service causing a delay to outbound payment processing between 22:38 and 23:40 UTC.

Service auto-recovered at 23:40 UTC with no further impact to payments.

Root cause is being investigated by Form3 to identify preventative measures and put in place mitigation to prevent future issues.

Posted Nov 02, 2023 - 17:00 UTC

Resolved
The issue affecting Form3 - UK Instant service has been resolved as of 23:40 UTC.

We have confirmed, following a period of monitoring, that the service has returned to normal processing and no further degradation has been observed.

Further details will be provided in the postmortem in due course.
Posted Oct 28, 2023 - 00:40 UTC
Monitoring
We can confirm service has returned to normal processing and no further degradation has been seen since 23:40 UTC.

We continue to monitor the service to ensure appropriate mitigation is in place.
Posted Oct 28, 2023 - 00:28 UTC
Investigating
Form3 are investigating a performance degradation to the Form3 - UK Instant service.

Customers may experience latency with payment processing.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Oct 27, 2023 - 23:58 UTC
This incident affected: Form3 - UK Instant (Direct (IRE)).