INC159967 - Degradation to Form3 - UK Instant and Form3 - SEPA services
Incident Report for Form3
Postmortem

Between 14:55 - 15:05 UTC on Friday the 22nd of September, we identified an issue impacting the processing times of payments on both Form3 – UK Instant and Form3 – SEPA Instant services.

Root cause was isolated to an issue with our Network Security Provider.

Form3 are working with our Network Security Provider to identify and implement measures to prevent a reoccurrence

Posted Oct 02, 2023 - 10:48 UTC

Resolved
From 14:55-15:05 UTC, Form3 experienced an impact to the Form3 - UK Instant and Form3 - SEPA services

We have investigated the issue and can confirm during this time some customers may have experienced slow processing times.

The issue was resolved at 15:05 UTC and after a period of monitoring, our Incident Response Team have confirmed there is no ongoing impact. Root cause was isolated to an issue with our network security provider.

Further details will be provided in the postmortem in due course.
Posted Sep 22, 2023 - 16:13 UTC