INC134654 - Degradation to the Form3 - UK Instant service
Incident Report for Form3
Postmortem

On Thursday 20th July 2023, Form3 observed a degradation to the Form3 UK Instant service causing a delay to outbound payment processing between 17:46 and 18:02 UTC.

Service auto-recovered at 18:02 UTC with no further impact to payments.

Root cause is being investigated by Form3 to identify preventative measures and put in place mitigation to prevent future issues.

Posted Jul 21, 2023 - 16:26 UTC

Resolved
The issue affecting Form3 - UK Instant service has been resolved as of 18:02 UTC.

We have confirmed, following a period of monitoring, that the service has returned to normal processing and no further degradation has been observed.

Further details will be provided in the postmortem in due course.
Posted Jul 20, 2023 - 19:00 UTC
Monitoring
Form3 observed a performance degradation to the Form3 - UK Instant service on outbound payments between 17:46 UTC and 18:02 UTC.

We can confirm service has returned to normal processing and no further degradation has been seen since 18:02 UTC.

We continue to monitor the service to ensure appropriate mitigation is in place.
Posted Jul 20, 2023 - 18:17 UTC
Investigating
Form3 are investigating a performance degradation to the Form3 - UK Instant service.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Jul 20, 2023 - 18:12 UTC
This incident affected: Form3 - UK Instant (Direct (IRE)).