INC421684 - Major Outage to the Form3 - Metrics service

Incident Report for Form3

Postmortem

On Wednesday 10th December, Form3 observed a degradation to the Form3 Metrics API service between 19:00 and 20:30 UTC, followed by a full outage of the service between 20:30 and 22:48 UTC.

The issue was resolved as of 22:48 UTC and after a period of monitoring, our Incident Response Team confirmed there was no further impact.

Additional details will be provided in the postmortem in due course.

Posted Dec 15, 2025 - 16:40 UTC

Resolved

The issue affecting Form3 - Metrics service has been resolved.

We have confirmed, following a period of monitoring, that the service has returned to normal processing and no further degradation has been observed.

Further details will be provided in the postmortem in due course.
Posted Dec 10, 2025 - 23:30 UTC

Monitoring

A fix has been implemented and we are in a period of monitoring.

Impacted customers should now see that normal processing has resumed on the Form3 - Metrics service.

We will continue to monitor and update accordingly.
Posted Dec 10, 2025 - 22:48 UTC

Identified

We are working with our 3rd Party Provider to resolve the issue as a priority.

We will post an update as soon as more information becomes available.
Posted Dec 10, 2025 - 22:11 UTC

Investigating

Form3 are investigating a major outage to the Form3 - Metrics service.

Investigations are ongoing and an update will be provided as soon as more information becomes available.
Posted Dec 10, 2025 - 20:30 UTC
This incident affected: Form3 - Metrics.